r3 - 17 Sep 2009 - 15:00:21 - XinZhaoYou are here: TWiki >  Admins Web > UpgradeSL5

UpgradeSL5

Introduction

From: "Ernst, Michael" 
Date: August 12, 2009 6:48:56 AM CDT
To: 
Cc: "Rob Gardner" 
Subject: SL5 migration
Dear Colleagues, Now that computing management of all four LHC experiments have signed off on the migration to SL(C)5 the WLCG management asks all Tier-1 and Tier-2 sites to carry out the transition as soon as possible. Following the migration of the U.S. ATLAS Tier-1 center about two weeks ago numerous validation tasks of various kinds were run by ADC central operations and have proven that the ATLAS software is in a state allowing ATLAS computing management to confirm readiness for an SL(C)5 based processing infrastructure. At our weekly computing meeting later today we will address this point in detail.

Regards, Michael

From: Ian Bird [mailto:Ian.Bird@cern.ch] 
Sent: Wednesday, August 12, 2009 4:11 AM
To: worldwide-lcg-management-board (LCG Management Board)
Subject: MB Summary: agreement SL5 migration
 

Dear colleagues,

As agreed in the Management Board on August 4, now is the time to push to complete the SL5 migration at all sites, including the Tier 2s. It was understood in the meeting that the experiments are all ready and able to use SL5 resources. A web page is available to provide pointers to the relevant information to support the migration, including links to the necessary packages. (https://twiki.cern.ch/twiki/bin/view/LCG/SL4toSL5wnMigration)

It is now expected that Tier 1s and Tier 2s should plan this migration as rapidly as possible, so that the majority of resources are available under SL5 as soon as possible.

Regards,

Ian

ATLAS SL5 twiki

SL 5.3 x86_64 migration at BNL

 
From: Chris Hollowell 
Date: July 29, 2009 4:04:27 PM CDT
To: usatlas-grid-l@lists.bnl.gov
Subject: [Usatlas-grid-l] BNL x86_64 SL 5.3 Worker Node Package List

Some USATLAS Tier2/3 sites have expressed interest in obtaining the package list from our processor farm's 64-bit Scientific Linux 5.3 OS image. To help these sites build worker nodes which are similar to our own, I've attached the "%package" section from our x86_64 SL 5.3 Kickstart configuration.

Notes:

  • The 32-bit/i386 openssl097a and compat-readline43 SL4 compatibility packages were not part of the initial x86_64 SL 5.3 release. Only the 64-bit RPMs were available until June 15, when the 32-bit versions were pushed into the x86_64 SL 5.3 updates repository http://ftp.scientificlinux.org/linux/scientific/53/x86_64/updates/security/
  • The 32-bit compat-glibc-headers-2.3.4 package, which is not in the attached list, should be obtained and installed from the 32-bit/i386 SL 5.3 distribution: http://ftp.scientificlinux.org/linux/scientific/53/i386/
  • /usr/lib/libblas.so should be created as a symbolic link to /usr/lib/libblas.so.3.0.3
  • If you have a local dCache installation, and plan on mounting a dCache PNFS filesystem on your worker nodes, you may want to consider installing a patched nfs-utils package. Without it, you may not be able to gracefully unmount PNFS from your nodes. This is particularly important if you're using autofs to mount PNFS. More information is available here: https://bugzilla.redhat.com/show_bug.cgi?id=513466
  • packages.txt: packages.txt
-----------------------------------------------------------------
Chris Hollowell  - Advanced Technology Engineer
RHIC/ATLAS Computing Facility [https://www.racf.bnl.gov]
Physics Department, Brookhaven National Laboratory
______________________

Patch to atlas releases 15.3.1 and prior

  • To make sure the jobs use the correct compiler, patches need to be applied to old releases 15.3.1 and prior. Without the patch, analysis jobs involving compilation will fail on SL5 platform. Applying the patch to sites running SL4 platform is harmless.
  • The patch should have been applied to all sites by the software installer. If you want to do it yourself, below is the instructions:
    • cd (as the owner account of $OSG_APP/atlas_app/atlas_rel directory)
    • download the patch tarball from http://www.usatlas.bnl.gov/~xinzhao/installSW/patch-slc4-to-slc5.tar.gz
    • untar it and there should be 4 files : patch-slc4-to-slc5.sh, AtlasLogin? -AtlasSettings-slc4compat.tgz, AtlasCore? _PlatformPolicy.tgz, AtlasCore? _SLC4_Compat.tgz
    • run the script as
      • ./patch-slc4-to-slc5.sh $kit_dir (where $kit_dir is the full pathname to the target release, i.e. $OSG_APP/atlas_app/atlas_rel/)
  • Any problems please contact Xin Zhao (xzhao@bnl.gov) and Shuwei Ye (yesw@bnl.gov)

References


-- RobertGardner - 12 Aug 2009

About This Site

Please note that this site is a content mirror of the BNL US ATLAS TWiki. To edit the content of this page, click the Edit this page button at the top of the page and log in with your US ATLAS computing account name and password.


Attachments


txt packages.txt (8.7K) | RobertGardner, 12 Aug 2009 - 11:10 |
 
Powered by TWiki
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback